Won't let me login to the FTB Launcher

generallauncher

#1

None of the categories describe my problem so sorry.

Modpack/Launcher: FTB Infinity Evolved

Using a MacBook Pro with macOS Mojave Version 10.14.2

I’m having issues logging into my Minecraft account on the FTB profile so I can go join a server. I know my email and password are 100% correct, I used it to log into Mojang.com, minecraft.net and the regular Minecraft launcher just now.

However when I go into create a profile, put it my email and password and then hit launch on Infinity Evolved, I get this popup error:

"Invalid username or password!

  • Check your username or password. If you use OLD non-migrated account try using username instead of email.
  • You need to use paid minecraft credentials. Mojang account without paid MC won’t work."

And I get this console error:

"Invalid credentials recieved for user: (my email):
com.mojang.authlib.exceptions.InvalidCredentialsException: Invalid username format. Username must have between 4 and 16 and alphanumeric characters. Underscore is allowed."

My account is migrated so I know its uses email. I have certainly paid for Minecraft as I can get onto any server in vanilla Minecraft. I’m not sure why the its asking between 4 - 16 characters when it says Username/Email. I’m thoroughly confused and just want to play a modpack on a server with my friends.

Update: I just tried creating a profile using a friends account that he just launched with and I got the same error message, even though the email and password are correct and he was able to launch.


#2

can you post full log please, instructions for that can be found here:
https://support.feed-the-beast.com/faq/


#3

Does this suffice:

https://pastebin.com/rZJpLsGY


#4

Not really, but try and delete the profile restart the launcher and re-add your account.

If it still fails, please follow the instructions on how to post the log.


#5

Removed profile, restarted launcher, and added back profile.
https://paste.feed-the-beast.com/view/4f6249d4


#6

Haven’t used osx in a while, and don’t have either osx or linux close by atm.

First - really make sure that you don’t get a space or other character if you copy/paste your username and/or password - then try:

  • Close launcher

  • Try and find where the files “clientToken” and “logindata” are stored, and remove those)

  • Try again, post new log if it still fails


#7

Removed clientToken and logindata and tried again.
https://paste.feed-the-beast.com/view/48b4cf62

I keep seeing this 4-16 alphanumerical prompt in the Console, which is strange for the reason I said before but I have a feeling its why I can’t launch. It’s as though its requiring me to use a Username even though my account is Email based.

I tried using my Minecraft username in place of the email before starting this thread, and it let me launch the modpack. However I got the Invalid Session error trying to join my friends server.
Through further testing I realized It didn’t actually log me into my Minecraft account when I used the Username. I went into singleplayer and had no skin, as well as the fact I can use any Username and any password and still launch, but obviously getting the Invalid Session error as those accounts aren’t real.


#8

any antivirus software or restrictions on folders?

If you open up the logindata file, did the launcher managed to save the new profile in that file?


#9

Yes my Antivirus software is a program named SOPHOS. However I believe my settings it put restrictions on applications and folders and such. It just scans and prevents malicious content.

This is the Text the logindata brings up, so I assume yes it did save. All the question marks are User and folder data I assume.

¨Ìsrnet.ftb.data.UseraIa_serialZsaveMojangDataL_encryptedPasswordtLjava/lang/String;L_encryptedStoreq~L_nameq~L _[email protected][email protected]~x

Also, thanks for the time and help, if you got nothing it’s aight. My next plan is to just try a different computer entirely.


#10

Can you show me a log when you use username instead of e-mail?


#11

Used username.

https://paste.feed-the-beast.com/view/cccd4398

As the launcher loaded, the logs show all the modpack loading too. Guess you only need to look at the first bit though.


#12

Looks strange.

You could try and re-install everything - (make sure to remove all - the folders at the location of logindata as well)

Then make sure to whitelist/make exception for the game in your antivirus software, looks like something is blocking - or some left over since before you did the migration?

You could also try the Twitch app and see if that works out.
red download button: feed-the-beast.com

or try the MultiMC launcher and see if you can manage to get around the issue there.


#13

I’ll try all these tomorrow, have too much work to do tomorrow to stay up much longer.

If all those fail I’ll let ya know and just try on a different computer, which should work (knocking on wood).

Night, and thanks for the time.