Sky Factory 3 world not loading

skyfactory3

#1

Modpack Name: Sky Factory 3

Modpack Version: Sky Factory 3 v3.0.15

Launcher Version: v1.4.17

Link to Log (Required): https://paste.feed-the-beast.com/view/0e4ad09b (I opened the world 3 times :frowning_face:)

Have you made any changes to the pack? (If yes please list the changes): No

Issue Details: Every time I open my world (single player) it keeps loading for ever and the log just states (The state engine was in incorrect state SERVER_STARTING and forced into state SERVER_STOPPED. Errors may have been discarded.) this is happening right after my city had a blackout, idk if the world is corrupt or if it’s just one mod that is causing this, but I really need help, I was really far away in the modpack…


#2

If you’re unlucky your world is corrupted, but checking your log it might just be the island.json file.

Find that file and delete it (store it somewhere else and it will be recreated when you boot next time)

If it still fails, post new log.


#3

is it the file that is stored outside of the world file?


#4

If I remember correctly it’s badly placed in the config folder

Should be better of in the world folder.


#5

same thing happened and it created another island.json file
new log: https://paste.feed-the-beast.com/view/19a44da8


#6

Your save is most likely corrupted and best way forward is to restore to the latest backup - check the backups folder and restore your world from that.

(you could make a manual backup of current broken one before replacing with a backup, just in case you want it in the future)

Post new log if it still fails.


#7

It worked! Thank you very much, I didn’t know there was a backup folder lol


#8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.