Need help with trying to join my friend's FTB Revelation server


#1

Me and my friend are using LogMeIn Hamachi instead of port forwarding. I’ve tried to join the server but it says Timed out, although my friend sees that I left the game before I have even joined. I’ve been using McAfee firewall and have let Minecraft, LogMeIn Hamachi, and Java through the firewall’s whitelist. We’ve read a lot of forums on here with people that have had the same problem but it hasn’t worked for us. I don’t know how to find the logs if somebody could help me out that would be awesome.


#2

Why not use portforward?
Sounds like you making it way too complicated with your current setup.


#3

Port forwarding doesn’t work for some reason


#4

Doesn’t work how?

Did you do the port forward on the router/firewall?

And also open the port in the local firewall on the machine running the server?


#5

Hey, I am the server host and Kuroday is my friend playing on it. I’ll answer the questions you have for him.

Yes I did port forward on the router with the 25565 port. I don’t think I opened the port in the local firewall on the machine though. My friend and I used to use port forwarding for playing together but one day it stopped working so we’ve been using Hamachi ever since and its been working fine. I try and get the port forwarding working first though. I will let you know if the local firewall was the problem!


#6

So I port forwarded the 25565 port through windows defender firewall (both TCP and UDP) and made sure the router is port forwarding the same thing, yet the port is still blocked. I checked using canyouseeme.org but it still just says:

Error: I could not see your service on *(my ip) on port ( 25565 )

Yes, I also checked to see if my friend could join the server using my IP, and it said this message:

io.netty.channel.AbstractChannel$AnnotatedConnectException: Connection refused: no further information:

No idea why the problem persists even though I have done the port forwarding correctly. Any solutions?


#7

I cannot guarantee that I have a specific solution for your problem, but I just want to mention that it seems that recently Java is causing problems in terms of connecting to FTB Revelation servers.

I recently experienced having problems connecting to my local server where a re-install (of a newly installed Java) worked. Then I experienced the same on another computer and found out that simply clearly that Java cache (temporary files - in Java through the Control Panel) did the trick as well.


#8

This really doesn’t have anything with the issue @Shadowtale is having.

Can you share exactly how you set it up - share screenshots and don’t mask IP addresses. If you don’t want to post that public here, feel free to send a direct message to me here - and I’ll check those out and give a relevant answer here based on the information.

Also share your server.properties file, use a paste site and give the link.


#9

I sent you a DM of all the pictures and some info behind them. I just sent a picture of the server.properties file, but if you need me to use a paste site, let me know!


#10

Got the info - due to the nature of your info, i’m going to answer you there - and when we solved it we’ll add the solution here - but without your personal information, in case anyone else finds this and have similar issue.