FTB Revelations Server Setup Issue

feedthebeast

#1

Modpack: Revelations

Modpack Version: 2.7.0

My current understanding is that once the server files have been extracted to a new folder, the “ServerStart.bat” file would be run, which would receive the necessary files for server complete server setup (EULA, properties etc). However, when I run the file, or any .bat file from the .zip, the application flashes open for a split-second before immediately closing. I am able to run other batch files on my PC, and am fairly certain I have the latest version of 64bit java installed so I’m unsure as to what exactly the issue is. Any help would be appreciated.


#2

What version?

Can you check if there’s any log created (check logs folder), or crash-report?

If not, can you try and get a screen shot or anything that you might be able to share - showing something about your issue.


#3

I have version 8 (update 171) installed.

No log seems to have been created. Here is a recording of the issue.


#4

In what folder did you put the server?
(please show full path)


#5

I extracted the files into a new folder located on the desktop (I named it FTB Server, although I assumed the name was irrelevant).

Full path is: C:\Users\Clayton-DT\Desktop\FTB Server


#6

Is your desktop a part of your Ondrive?

Do you have any 3rd party Antivirus software on your machine?


#7

OneDrive is on the machine (windows 10), but it is has not been set up, so that’s a negative. Regarding the antivirus, the only security are Windows Firewall and Windows Antivirus Defender, both of which are active. As an aside, I went ahead and turned off the “real-time protection” found in the settings, and the .bat still refused to work.


#8

After making my own batch file (this time including the full path to the jarfile) I was partially successful in “running” it. However, it appears there are some essential files that are listed as missing.


#9

First time you run ServerStart.bat it triggers FTBInstall.bat - that downloads the needed files.

Can you do:

java -version

and show me the outcome


#10


#11

Try and create a new folder directly under c:\ (like c:\games) - and put the server as a sub folder there.


#12

Just tried this and the problem persists. Path was “C:\Games\FTB Server”.


#13

Questions:

1 - Is this a legit version of windows?

2 - Have you disabled UAC?

3 - Is this a company owned machine?

4 - Are you trying to run this elevated (as administrator)?- if yes, stop that, if no - don’t do it!


#14

Answers:
1 - Yes, this is a licensed copy of Windows 10
2 - I have disabled the UAC
3 - This is my personal desktop
4 - I have not been


#15

Enable UAC - why did you even turn that off?


#16

Enable UAC - why did you even turn that off?

My mistake, I assumed you were offering that as a possible fix. The file still isn’t behaving whether or not the UAC is on or off.


#17

Perhaps you should do a hijack scan and share the result from that:

(instructions borrowed from #minecrafthelp (irc-channel with community help for vanilla minecraft)

Trend Micro HijackThis is a utility that is used to collect diagnostic reports of your computer to help narrow down an issue you may be having. Download: https://sourceforge.net/projects/hjt/files/latest/download

Run the program, choose “I accept”, then “Do a scan and save a log file”. After a while a text file will open. Copy everything, put the log on paste.feed-the-beast.com and share the link


#18

Sorry for the delay, had some midterms get in the way.
Here is the URL: https://paste.feed-the-beast.com/view/bdcc40ba


#19

A question about this:

image

Are you running a cracked version of steam?


#20

No, none of my applications are cracked.