FTB Revelation - Extreme lags / Can't load world

crash
feedthebeast
revelation

#1

Hi,
I have been trying to play FTB Revelation for a few days now still with no success. At first, i was unable to even launch it due to being stuck at loading at 6/7 (JEI), solved that with selecting JAR launcher and adding
“-d64 -server -XX:+AggressiveOpts -XX:ParallelGCThreads=3 -XX:+UseConcMarkSweepGC -XX:+UnlockExperimentalVMOptions -XX:+UseParNewGC -XX:+ExplicitGCInvokesConcurrent -XX:MaxGCPauseMillis=10 -XX:GCPauseIntervalMillis=50 -XX:+UseFastAccessorMethods -XX:+OptimizeStringConcat -XX:NewSize=84m -XX:+UseAdaptiveGCBoundary -XX:NewRatio=3 -Dfml.readTimeout=90 -Ddeployment.trace=true -Ddeployment.log=true -Ddeployment.trace.level=all” to the Java arguments…
Now, I get to the menu after ± 10 minutes, but after that, i have extreme lags even in the menu and I cant load any world. Neither create new SP, or load a MP…
I have 8GB in my PC, 6GB allocated. Tried with 5.5GB, 5GB and 4GB as well withou any change.
I was able to play this modpack in the past, but now I’m stuck here… I tried reinstalling modpack several times, also tried reinstalling the whole launcher with no success. I’m using Twitch launcher.
Also, I tried the modpack FTB Beyond with the same results…

Here is a link to the latest log (doing this the first time so I hope I am pasting the right thing):
https://paste.feed-the-beast.com/view/a6ee0826

I appreciate any suggestion or help, thanks…

EDIT
Now I tried it with FTB Legacy Launcher with console on and I noticed there have been a lot of red writing and problems with TConstruct, PneumaticCraft and a lot more mods… Could this be some problem with launchers not downloading the modpack properly?


#2
  1. Update your graphics driver and then restart your computer.
  2. Remove the added arguments and just use default.
  3. Do a repair of the pack, instructions for that can be found here: https://support.feed-the-beast.com/faq/

If you still have issues, post new log and answer all these questions:

  • Are you using any 3rd party antivirus software or other security software on that machine?
  • Is your documents folder part of your OneDrive installation?
  • What CPU do you have?
  • Is it running on HDD or SSD?

#3

Did all you have asked, now i won’t get past Phase 6/7, Loading Complete - Just Enough Items, Loading recipes XXX/±300 000… It loads about 2 recipes each 3 seconds and then the whole MC freezes for a second, then again and again…

Here is the new log:
https://paste.feed-the-beast.com/view/0cd2aa2c

  • I am not using any 3rd party antivirus, just windows defender.
  • I don’t use OneDrive. I have it installed, but never synced anything with it. When i open it, there is a Documents folder, but that is a different one and is empty.
  • CPU = IntelCore i7-7700HQ, 2,8GHz
  • It is running on HDD.

Thank you for your help


#4

This is on the low end and might be part of the issue, but should still launch (if there’s enough free at the time of launch)

3rd party might some times block, and whitelist/exception is need to be add - so good that we got that cleared :slight_smile:

If gamefolder is placed in OneDrive (or other sync applications folder), then it will fail - so good that we cleared that one as well

No worries there - not the best one, but in mid range and should handle this without any issues.

This might cause slower loading times, but should not be a show stopper. Just make sure there’s enough free space on the drive.

Nah, there are a lot of false positives in the logs on errors and information.

But if you had that launcher installed as well - can you share a log from that as well - and I’ll check that as well.

If you mind, can you try other packs as well.

Try these 2 and provide logs as well, if you have the time and energy, from both launchers:

Direwolf20 1.10 version
Direwolf20 1.12 version

Instructions for getting log from the legacy launcher (and from Twitch app too), can be found here:
https://support.feed-the-beast.com/faq/


#5

So in FTB Legacy launcher, I tried the FTB Revelations without getting past phase 6/7, the same JEI stuff…
Logs to this: https://paste.feed-the-beast.com/view/1d40fce7

Then I tried the FTB Direwolf20 1.12 using Twitch Launcher… This modpack loaded without a problem in about 10 mins, another 5-10 mins creating new SP world and when it loaded, it was doing the same thing as with Revelation… The 3 seconds working, then freeze for a second and again… This I tried with only 4GB RAM allocated, so maybe there is the problem in this case.
Logs: https://paste.feed-the-beast.com/view/ec9a6af8

After this I went for FTB Direwolf20 1.10 using Twitch Launcher… This loaded really fast, in about 3 mins and in another 5 mins it was able to create a new world… This version I tried with 5,5GB RAM allocated and after loading the world, it worked without problem…
Logs: https://paste.feed-the-beast.com/view/e7314ba5

I am really thankfull for your help and that you take the time to go through those logs, I appreciate it a lot. Right now I don’t have time to try the Direwolf20 modpacks on FTB Legacy Launcher, will add later if necessary.
Thank you one more time…

Just to add, I tried other big modpacks like ATM 3 with same result as Revelation and Sevtech Ages, where I was able to join a MP server, but with extreme lags…


#6

Both ATM3 (and especially the latest Remix) requires 8gb allocated.

Revelation should load on 4-6gb allocated.

Taking the information that also Dw20 1.12 was slow and had issues while loaded, perhaps there’s a issue with your ram? (or that your total amount is on the limit and there’s some combo on your hardware that makes this not work)

I would suggest that you scan your memory with memtest (the built in usually doesn’t detect issus like memtest does - but you could start with that - just search for “Windows Memory Diagnostic” on your start menu, the system will reboot and run tests)

If that shows anything strange then we’ll know, if it doesn’t - run https://www.memtest86.com/ (this will take a while, and you can not use the machine while it runs).

Even if there’s no issue with the hardware, like mentioned, there might be a combo, or something way to close to the limit - so if you’re able to - add more ram in your machine. (I would still do the scan, just to be sure).

EDIT: Also - check your HDD, perhaps using SSD for the OS and your games, that would also get better performance when gaming.


#7

Unfournately, I am not able right now to add more memory to my laptop. On the other hand, maybe it has something to do with HDD. Since I bought the PC, I sense that there is something wrong with it… I think my HDD might be damaged in some way :confused:


#8

Most laptops you can swap the disk - see if you can get hold of a SSD - that would make a huge difference for you.


#9

Well, i have an MSI laptop and i can’t open it without voiding the warranty (sticker over screw). I think that those models I have were sold with SSD as well, so maybe I even have a slot inside. Ill see to this.
Thank you for your time and help, glad someone at least tried :))